Topics Map > Software Guides > Premiere

Premiere: Adding Text (Titles)

Version: Adobe Premiere Pro 2020. Be aware that different versions of Premiere will vary in appearance and functionality. Full Guide: View/Download


Titles refer to clips of text that can be placed over the top of a video clip or on a solid background. They can be used to name a movie, add credits, or for any other text-based needs. Titles can be created in two ways: through Legacy Title (File > New > Legacy Title), as well as the Type tool. The method described below is the latter.

To create a new title:
  1. Select the Type tool, which looks like a T, from the Toolbar.

  2. Click within the Program Window and a red text box will be created. A new title clip will also be added to the Timeline at the playhead. 
  3. Type desired text.

  4. Navigate to Window > Essential Graphics. The Essential Graphics panel will appear, which is where text formatting can be edited. 
  5. Click the “Edit” tab in the Essential Graphic panel and format text as desired (options described in the sections below).

Title clips can be modified the same way as photo and video clips in the Timeline. To show the text over a visual clip, click-and-drag it to be on top of the clip in the Timeline. If a title isn’t stacked on top of another clip, it will appear on black. 

Editing Options

Layers: Title text is contained within text boxes, and each text box is placed on its own layer. Layers are edited independently of each other. Similar to tracks, layers are placed on top of each other in a stack, which makes the top layer is the most visible. The layers of a Title are displayed in the Edit tab of the Essential Graphics window near the top. 



Basic layer controls:
  • To modify the text, select it within the Program Window or its layer in the Essential Graphics panel.
  • To add a new text layer, click the New Layer button to the bottom-right of the layers and select the desired option from the pop-up. Shapes can be added.
  • To re-order a layer, click-and-drag the layer up or down.
  • To delete a layer, right-click it and select “Clear” from the pop-up.

Responsive Design: pin the selected text layer to the video frame or a different layer. When the video frame/other layer is moved, the pinned layer will move with it.


Align and Transform: adjust the position of the layer. Click-and-drag the text box within the Program Window, or change the values in this panel.


Master Styles: create and apply Master Text Styles for later use. Only recommended for Title-heavy projects.


Text: formatting options such as font, size, weight, and alignment within the text box. 


Appearance: click the colored rectangle or utilize the eyedropper to adjust the color of each option. Check each box to apply the options.

  • Fill: the main color of the characters.
  • Stoke: outer border of the characters. Adjust the size of the stroke with the number field to the left of the eyedropper.
  • Shadow: drop shadow. Adjust the transparency, angle, distance, and blur of the shadow.
To create rolling credits, such as for the end of a movie, deselect all layers and check the “Roll” option that appears. Adjust timing as desired.


Guide Index:


iTech logo
Need support? Contact itech@plu.edu or visit www.plu.edu/itech.




Keywords:Adobe, editing, video, audio, movie, text, titles, credits   Doc ID:100578
Owner:Misty B.Group:Pacific Lutheran University
Created:2020-04-14 11:35 PDTUpdated:2020-04-21 12:56 PDT
Sites:Pacific Lutheran University
Feedback:  0   0