Topics Map > Software Guides > Photoshop

Photoshop: Masking

Version: Adobe Photoshop CC 2020. Be aware that different versions of Photoshop will vary in appearance and functionality. Full Guides: Photoshop: Images, Photoshop: Graphic Design


Masking can be used to hide portions of a layer. Any effects made to a masked layer, such as image Adjustments or Layer Styles, will affect only the masked area. Masking can also be used to collage or combine multiple images.

To mask an object/area:
  1. Select the layer with the desired object/area to mask in the Layers panel.
  2. Highlight the object/area with a Selection tool, such as the Quick Selection tool (see Photoshop: Selection Tools for more details).
  3. Click the Add layer/vector Mask button to the bottom of the Layers panel. Only the selected area will remain and a mask will be added to the layer. The Properties panel should open.
    • If the Properties panel doesn’t automatically open, double-click the mask in the layer.

  4. Click “Select and Mask” in the Properties panel.
  5. Use the adjustments to refine the selection, which will help it blend with other images/objects in the project.
    • View Mode: use the drop-down to change the preview background color. This can be helpful to see the edges of the mask more clearly.
      • Opacity: set the transparency of the background color.
    • Edge Detection - Radius: determines the size of the selection border in which edge refinement occurs. Use a small radius for sharp edges, and a large one for softer edges.
      • Smart Radius: Allows for a variable width refinement area around the edge of the selection. Among other use cases, this option is helpful if the selection is a portrait that includes both hair and shoulders. In such portraits, the hair might require a larger refinement area than the shoulders, where the edge is more consistent.
    • Smooth: reduces irregular areas in the selection border to create a smoother outline.
    • Feather: blurs the transition between the selection and the surrounding pixels (don’t overdo!).
    • Contrast: when increased, soft-edged transitions along the selection border become more abrupt. 
    • Shift Edge: Moves soft-edged borders inward with negative values or outward with positive ones. Shifting these borders inward can help remove unwanted background colors from selection edges.
    • Output settings - Decontaminate colors: replaces color fringes with the color of fully selected pixels nearby. The strength of color replacement is proportionate to the softness of selection edges. 
  6. When done, click OK.
The masked selection will appear on a transparent background, which is indicated with a checkerboard pattern, or on top of any layers that are below it in the Layers panel. The original unmasked area will be removed. 

The Brush tool can be used to add or subtract from the masked area. This can be helpful for removing parts of the image that were inadvertently selected before masking. Use white to add to the selection, and black to subtract, and paint over the desired areas.

To reopen the Properties panel and edit the mask settings at any time, double-click the mask on the layer in the Layers panel.



Collaging & Combining Images

Images or parts of images can be collaged together to create something completely new. Collaging has a range of uses, including adding people/objects to images and changing background. In the example below, an object/element from one image will be combined with a different image for the background. Two viable methods are described below.


Method 1

  1. Navigate to File > Open, and open each image separately. 
  2. Navigate to the image that has the object/element to be combined with the other background image. 
  3. Use a Selection tool, such as the Quick Selection tool, to select the desired object/area (see Photoshop: Selection Tools for more details).

  4. Click the Add layer/vector Mask button to the bottom of the Layers panel and make adjustments as desired (see above for details). 

  5. Right-click the layer in the Layers panel, and select “Duplicate layer” from the pop-up that appears.
  6. In the Document drop-down, select the background image that should be already open in a separate window, rename the layer if desired, and click OK.
  7. Use the Move tool to relocate the image. 
    • Resize: ensure “Show transform controls” is selected in the Options bar, and then click-and-drag the handles that appear on the sides of the image.
To adjust the mask at any time, double-click it from the Layers panel.

Method 2

  1. Navigate to File > Open, and open each image separately.
  2. Navigate to the image that has the object/element to be combined with the main image. 
  3. With the Move tool selected, copy the image (Command/Ctrl+C, or Edit > Copy).
    • If Edit > Copy is greyed out, navigate to Select > All and copy the image (Command/Ctrl+C).
  4. Navigate to the main image, and paste (Command/Ctrl+V, or Edit > Paste). A new layer for the second image will be created.
  5. Use the Move tool to relocate and resize the layer as desired.
  6. Use a Selection tool, such as the Quick Selection tool, to select the desired object/area (see Photoshop: Selection Tools for more details).

  7. Click the Add layer/vector Mask button to the bottom of the Layers panel and make adjustments as desired (see above for details).


Guide Index:


iTech logo
Need support? Contact itech@plu.edu or visit www.plu.edu/itech.




Keywords:graphic design, cutting, editing   Doc ID:106120
Owner:Misty B.Group:Pacific Lutheran University
Created:2020-09-23 13:05 PDTUpdated:2020-10-01 11:38 PDT
Sites:Pacific Lutheran University
Feedback:  0   0